How To: Setup RSpec, Cucumber, Webrat, RCov and Autotest on Leopard

Prerequisites I’m assuming you’ve got the following installed: ruby ruby gems 1.3.1 Apple development tools git rails >= 2.3.2 You’ve added github to your gem sources (gem sources -a http://gems.github.com) RSpec & RSpec-Rails First let’s grab the rspec1 and rspec-rails2 gems. sudo gem install rspec sudo gem install rspec-rails Cucumber Next we’ll install the cucumber3 gem